As you probably know, Joomla 1.5 has reached end-of-life. It's no longer supported, and you shouldn't use it. OK?

That said - there are situations where the use of Joomla 1.5 is inevitable. For instance, I regularly come across people who want me to help them port their site to the latest version of Joomla. Sometimes, the site can't be upgraded immediately. Perhaps there's a financial issue at hand. Other times, it can be that the site is so complex and full of outdated extensions and special solutions that it's not possible to migrate without building new components or find alternatives. This can take time, and while you find the solutions the site needs to stay secure. 

-->